码迷,mamicode.com
首页 > 其他好文 > 详细

Multiplication Puzzle POJ - 1651(区间DP)

时间:2018-01-30 23:06:42      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:c代码   ddl   can   layer   区间dp   状态   player   获得   ++   

Multiplication Puzzle
Time Limit: 1000MS
 
Memory Limit: 65536K
Total Submissions: 11466
 
Accepted: 7105
Description
The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.
 
The goal is to take cards in such order as to minimize the total number of scored points.
 
For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000
 
If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6 10 1 50 50 20 5
Sample Output
3650
 
题目大意:有n张卡片在一排,拿取n-2次,不能拿首尾的卡片,每次拿卡片时你都会获得卡片前一张数值卡片本身数值卡片后一张卡片数值三个数的乘积当做你的得分。现在你需要以一种顺序取走卡片使得你得到的分值最小,最后输出能得到的最小的分值。
 
解题思路:
一道区间DP的题目。设dp[l][r]表示区间[l,r]的最优解,则状态转移如下:
1、当r-l=2时,也即只有三个数时,显然dp[l][r] = num[l]*num[l+1]*num[r];
2、当r-l>2时,对区间的最后一个被拿走的数进行枚举,则dp[l][r] = min(dp[l][r], dp[l][i]+dp[i][r]+num[l]*num[i]*num[r]),其中l<i<r。
 
AC代码:
 
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int INF=0x3f3f3f3f;
const int MAXN=100+10;
int num[MAXN],dp[MAXN][MAXN];

int solve(int i,int j)
{
    if(dp[i][j]!=INF)return dp[i][j];
    if(j==i+1)return dp[i][j]=0;
    for(int k=i+1;k<j;k++)
        dp[i][j]=min(dp[i][j],num[i]*num[k]*num[j]+solve(i,k)+solve(k,j));
    return dp[i][j];
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            dp[i][j]=INF;
        printf("%d\n",solve(1,n));
    }
    return 0;
}

 

 

Multiplication Puzzle POJ - 1651(区间DP)

标签:c代码   ddl   can   layer   区间dp   状态   player   获得   ++   

原文地址:https://www.cnblogs.com/zhangzehua/p/8387207.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!