码迷,mamicode.com
首页 > 其他好文 > 详细

Codeforces 702 D Road to Post Office

时间:2018-01-31 18:31:40      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:rom   描述   amp   long   eset   for   vector   数学   nta   

题目描述

Vasiliy has a car and he wants to get from home to the post office. The distance which he needs to pass equals to ddkilometers.

Vasiliy‘s car is not new — it breaks after driven every kk kilometers and Vasiliy needs tt seconds to repair it. After repairing his car Vasiliy can drive again (but after kk kilometers it will break again, and so on). In the beginning of the trip the car is just from repair station.

To drive one kilometer on car Vasiliy spends aa seconds, to walk one kilometer on foot he needs bb seconds ( a<ba<b ).

Your task is to find minimal time after which Vasiliy will be able to reach the post office. Consider that in every moment of time Vasiliy can left his car and start to go on foot.

输入输出格式

输入格式:

 

The first line contains 5 positive integers d,k,a,b,td,k,a,b,t ( 1<=d<=10^{12}1<=d<=1012 ; 1<=k,a,b,t<=10^{6}1<=k,a,b,t<=106 ; a<ba<b ), where:

  • dd — the distance from home to the post office;

  • kk — the distance, which car is able to drive before breaking;

  • aa — the time, which Vasiliy spends to drive 1 kilometer on his car;

  • bb — the time, which Vasiliy spends to walk 1 kilometer on foot;

  • tt — the time, which Vasiliy spends to repair his car.

 

输出格式:

 

Print the minimal time after which Vasiliy will be able to reach the post office.

 

输入输出样例

输入样例#1: 
5 2 1 4 10
输出样例#1: 
14
输入样例#2: 
5 2 1 4 5
输出样例#2: 
13

说明

In the first example Vasiliy needs to drive the first 2 kilometers on the car (in 2 seconds) and then to walk on foot 3 kilometers (in 12 seconds). So the answer equals to 14 seconds.

In the second example Vasiliy needs to drive the first 2 kilometers on the car (in 2 seconds), then repair his car (in 5 seconds) and drive 2 kilometers more on the car (in 2 seconds). After that he needs to walk on foot 1 kilometer (in 4 seconds). So the answer equals to 13 seconds.

 

 

小学数学题。。。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<vector>
#define ll long long
using namespace std;
ll cost,d,b,a,k,t,n;
int main(){
    scanf("%lld%lld%lld%lld%lld",&d,&k,&a,&b,&t);
    ll xl=(a-b)*k+t,tim=d/k+(d%k?1:0);
    cost=min(b*d,d*a+(tim-1)*t);

    if(k<=d){
        if(xl>0) cost=min(cost,b*d-t+xl);
        else{
            n=d/k;
            cost=min(cost,xl*n+b*d-t);
        }
    }
    
    printf("%lld\n",cost);
    return 0;
}

 

Codeforces 702 D Road to Post Office

标签:rom   描述   amp   long   eset   for   vector   数学   nta   

原文地址:https://www.cnblogs.com/JYYHH/p/8393386.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!