码迷,mamicode.com
首页 > 其他好文 > 详细

1090. Highest Price in Supply Chain (25)

时间:2018-01-31 18:35:34      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:amp   contain   space   starting   ace   inpu   out   first   file   

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2

就是一颗多叉树,找出最深的叶子。

代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iomanip>
using namespace std;
int n,f[100005],t;
double p,r,m,price[100005];
int get(int k)
{
    if(!price[k])//如果价格为0 则执行下面语句
    {
        if(f[k] != -1)//父亲存在
        {
            get(f[k]);//计算父亲价格
            price[k] = price[f[k]] * r;
        }
        else price[k] = p;//父亲不存在 就是树根
    }
}
int main()
{
    cin>>n>>p>>r;
    r = (100 + r) / 100;
    for(int i = 0;i < n;i ++)
    {
        cin>>f[i];
    }
    for(int i = 0;i < n;i ++)
    {
        get(i);
        if(price[i] > m)m = price[i],t = 1;
        else if(price[i] == m)t ++;
    }
    printf("%.2f %d",m,t);
}

 

1090. Highest Price in Supply Chain (25)

标签:amp   contain   space   starting   ace   inpu   out   first   file   

原文地址:https://www.cnblogs.com/8023spz/p/8393458.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!