码迷,mamicode.com
首页 > 其他好文 > 详细

枚举--最长单词--蓝桥杯

时间:2018-01-31 20:17:39      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:字符串   char   价值   body   组成   end   处理   pos   col   

  编写一个函数,输入一行字符,将此字符串中最长的单词输出。
  输入仅一行,多个单词,每个单词间用一个空格隔开。单词仅由小写字母组成。所有单词的长度和不超过100000。如有多个最长单词,输出最先出现的。
样例输入
I am a student
样例输出
student
#include <iostream>
#include <string.h>

using namespace std;
int main()
{
	char a[100000];
	int j;
	int t;
	int c;
	int max=0;
	int i=0;
	int k=0;
	j=0;
   gets(a);
   //printf("%s",a);
   k=strlen(a);
   //cout<<k;
	for(i=0;i<k;i++)
    {
        if(a[i]==‘ ‘||i==k-1)
        {
			c=i-j;
        	j=i+1;
        	if(c>max)
        	{
        	  max=c;
			  t=i;	
			}
		} 
	}
	for(int x=t-max;x<=t;x++)
	{
		cout<<a[x];
	}
	cout<<endl;
	return 0;
}

  这道题的参考价值是输入一串字符串怎么处理

枚举--最长单词--蓝桥杯

标签:字符串   char   价值   body   组成   end   处理   pos   col   

原文地址:https://www.cnblogs.com/jweie/p/8393597.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!