码迷,mamicode.com
首页 > 其他好文 > 详细

You Are the One HDU - 4283(区间dp)

时间:2018-02-01 22:08:47      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:and   define   多少   output   oom   顺序   tag   eof   dir   

You Are the One
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4762    Accepted Submission(s): 2264
 
 
Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
 
 
Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
 
 
Output
  For each test case, output the least summary of unhappiness .
 
 
Sample Input
2 5 1 2 3 4 5 5 5 4 3 2 2
 
 
Sample Output
Case #1: 20 Case #2: 24
 题意:每个人都有怒气值v[i],如果这个人第k个上台,那么他含有的怒气值为 (k-1)*v[i].
现在你有一个类似栈的小黑屋能够调整上台人的顺序,请问调整后所有人上台带来的最小怒气值是多少?
 
思路:dp[i][j]表示在区间i到j中最小的怒气值。
假设第i个人第k个上台,那么他后面人的怒气值在原有成都上还要加上k*(s[j]-s[i+k-1])
状态转移式为:
dp[i][j]=min(dp[i][j],dp[i][i+k-1]+dp[i+k][j]+k*(s[j]-s[i+k-1])+(k-1)*v[i]);
 
代码:
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#define INF 0x3f3f3f3f
using namespace std;
const int MAXN=110;
int dp[MAXN][MAXN],sum[MAXN],v[MAXN];

int main()
{
    int T,n,Case=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        sum[0]=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&v[i]);
            sum[i]=sum[i-1]+v[i];
        }
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            for(int j=i+1;j<=n;j++)
            dp[i][j]=INF;

         for(int len=1;len<n;len++)
        {
            for(int i=1;i+len<=n;i++)
            {
                for(int k=1;k<=len+1;k++)
                dp[i][i+len]=min(dp[i][i+len],v[i]*(k-1)+dp[i+1][i+k-1]+(sum[i+len]-sum[i+k-1])*k+dp[i+k][i+len]);
            }
        }
        printf("Case #%d: %d\n",Case++,dp[1][n]);
    }
    return 0;
}

 

You Are the One HDU - 4283(区间dp)

标签:and   define   多少   output   oom   顺序   tag   eof   dir   

原文地址:https://www.cnblogs.com/zhangzehua/p/8401291.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!