码迷,mamicode.com
首页 > 其他好文 > 详细

BZOJ1303: [CQOI2009]中位数图

时间:2018-02-03 18:57:35      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:sample   for   word   包含   一个   out   奇数   scan   namespace   

Description

给出1~n的一个排列,统计该排列有多少个长度为奇数的连续子序列的中位数是b。中位数是指把所有元素从小到大排列后,位于中间的数。
Input

第一行为两个正整数n和b ,第二行为1~n 的排列。
Output

输出一个整数,即中位数为b的连续子序列个数。
Sample Input

7 4

5 7 2 4 3 1 6
Sample Output

4
HINT

第三个样例解释:{4}, {7,2,4}, {5,7,2,4,3}和{5,7,2,4,3,1,6}
N<=100000

题目传送门

一开始死活不会搞
这是一个全排列嘛,所以b只有一个,还要求是奇数。。。
那这个序列肯定包含b啊。。。
那么把b设为0,>b设为-1,

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
int a[110000],l[210000],r[210000];
int main() 
{
    int n,b,pos;scanf("%d%d",&n,&b);
    for(int i=1;i<=n;i++) {
        int x;scanf("%d",&x);
        if(x<b)a[i]=1;
        if(x>b)a[i]=-1;
        if(x==b)pos=i;
    }

    int sum=0;l[n]=r[n]=1;  
    for(int i=pos-1;i>=1;i--) 
        sum+=a[i],l[sum+n]++;
    sum=0;
    for(int i=pos+1;i<=n;i++) 
        sum+=a[i],r[sum+n]++;
    int ans=0;
    for(int i=-n;i<=n;i++)
        ans+=l[n-i]*r[i+n]; 
    printf("%d\n",ans);
    return 0;
}

by_lmy

BZOJ1303: [CQOI2009]中位数图

标签:sample   for   word   包含   一个   out   奇数   scan   namespace   

原文地址:https://www.cnblogs.com/MT-LI/p/8410207.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!