码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1094. The Largest Generation (层级遍历)

时间:2018-02-05 12:42:16      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:ges   ios   ati   put   tail   test   ber   following   red   

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (0) is the number of his/her children, followed by a sequence of two-digit ID‘s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

分析

用邻接表建树,层级遍历更新数据,用last,tail更新层级

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
int main(){
    int n,m,father,son,num,last=1,tail,cnt=0,max=-1,level,tag=1;
    cin>>n>>m;
    vector<int> family[n+1];
    for(int i=0;i<m;i++){
        cin>>father>>num;
        for(int j=0;j<num;j++){
            cin>>son;
            family[father].push_back(son);
        }
    }
    queue<int> q;
    q.push(1);
    while(!q.empty()){
        int t=q.front();
        q.pop();
        cnt++;
        for(int i=0;i<family[t].size();i++){
            q.push(family[t][i]);
            tail=family[t][i];
        }
        if(t==last){
            last=tail;
            if(cnt>max){
                max=cnt;
                level=tag;
            }
            tag++;
            cnt=0;
        }
    }
    cout<<max<<" "<<level;
    return 0;
}

PAT 1094. The Largest Generation (层级遍历)

标签:ges   ios   ati   put   tail   test   ber   following   red   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8416658.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!