码迷,mamicode.com
首页 > 其他好文 > 详细

BZOJ1003: [ZJOI2006]物流运输

时间:2018-02-05 23:34:20      阅读:316      评论:0      收藏:0      [点我收藏+]

标签:com   list   i++   log   修改   content   targe   优化   last   

Description

  物流公司要把一批货物从码头A运到码头B。由于货物量比较大,需要n天才能运完。货物运输过程中一般要转
停好几个码头。物流公司通常会设计一条固定的运输路线,以便对整个运输过程实施严格的管理和跟踪。由于各种
因素的存在,有的时候某个码头会无法装卸货物。这时候就必须修改运输路线,让货物能够按时到达目的地。但是
修改路线是一件十分麻烦的事情,会带来额外的成本。因此物流公司希望能够订一个n天的运输计划,使得总成本
尽可能地小。

Input

  第一行是四个整数n(1<=n<=100)、m(1<=m<=20)、K和e。n表示货物运输所需天数,m表示码头总数,K表示
每次修改运输路线所需成本。接下来e行每行是一条航线描述,包括了三个整数,依次表示航线连接的两个码头编
号以及航线长度(>0)。其中码头A编号为1,码头B编号为m。单位长度的运输费用为1。航线是双向的。再接下来
一行是一个整数d,后面的d行每行是三个整数P( 1 < P < m)、a、b(1< = a < = b < = n)。表示编号为P的码
头从第a天到第b天无法装卸货物(含头尾)。同一个码头有可能在多个时间段内不可用。但任何时间都存在至少一
条从码头A到码头B的运输路线。

Output

  包括了一个整数表示最小的总成本。总成本=n天运输路线长度之和+K*改变运输路线的次数。

Sample Input

5 5 10 8
1 2 1
1 3 3
1 4 2
2 3 2
2 4 4
3 4 1
3 5 2
4 5 2
4
2 2 3
3 1 1
3 3 3
4 4 5

Sample Output

32
//前三天走1-4-5,后两天走1-3-5,这样总成本为(2+2)*3+(3+2)*2+10=32
 
 
一开始还以为要斜率优化吓死我 
这个是DP还是很好看的:
f[i]表示前i天的最小花费,易得公式:
f[i]=min(f[j]+cost[j+1][i]*(i-j)+K)
其中cost[j+1][i]表示j+1~i天中1~n的最短路
 
代码如下:

#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
struct node
{
    int x,y,d,next;
}a[110000];int len,last[30];
void inc(int x,int y,int d)
{
    len++;
    a[len].x=x;a[len].y=y;a[len].d=d;
    a[len].next=last[x];last[x]=len;
}
int n,m,K,head,tail,list[30];
int g[30][30],flag[30][110],dis[30],f[30];
int spfa(int st,int ed)
{
    for(int i=1;i<=m;i++)dis[i]=999999;
    head=1;tail=2;
    list[1]=1;dis[1]=0;
    while(head!=tail)
    {
        int x=list[head];
        for(int k=last[x];k;k=a[k].next)
        {
            int y=a[k].y;
            if((flag[y][ed]-flag[y][st-1])==0&&(dis[y]>dis[x]+a[k].d))
            {
                dis[y]=dis[x]+a[k].d;
                list[tail++]=y;if(tail==m+1)tail=1;
            }
        }
        head++;if(head==m+1)head=1;
    }
    return dis[m];
}
int main()
{
    int x,y,d,e;
    scanf("%d%d%d%d",&n,&m,&K,&e);
    memset(g,0,sizeof(g));
    for(int i=1;i<=e;i++)
    {
        scanf("%d%d%d",&x,&y,&d);
        if(g[x][y]==0||g[x][y]>d)g[x][y]=g[y][x]=d;
    }
    len=0;memset(last,0,sizeof(last));
    for(int i=1;i<=m;i++)
        for(int j=i+1;j<=m;j++)
            if(g[i][j]>0)
            {
                inc(i,j,g[i][j]);
                inc(j,i,g[i][j]);
            }
    scanf("%d",&d);         
    memset(flag,0,sizeof(flag));
     
    for(int i=1;i<=d;i++)
    {
        scanf("%d%d%d",&e,&x,&y);
        for(int j=x;j<=y;j++)flag[e][j]=1;
    }
    for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
            flag[i][j]=flag[i][j-1]+flag[i][j];
    f[0]=0;
    for(int i=1;i<=n;i++)
    {
        f[i]=999999;
        for(int j=1;j<=i;j++)
        {
            int t=spfa(j,i);
            if(f[i]>f[j-1]+t*(i-j+1)+K)
                f[i]=f[j-1]+t*(i-j+1)+K;
        }
    }
    printf("%d\n",f[n]-K);
    return 0;
}

by_lmy

 

BZOJ1003: [ZJOI2006]物流运输

标签:com   list   i++   log   修改   content   targe   优化   last   

原文地址:https://www.cnblogs.com/MT-LI/p/8419381.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!