码迷,mamicode.com
首页 > 其他好文 > 详细

BZOJ3894: 文理分科

时间:2018-02-09 15:40:20      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:science   正整数   href   online   logs   www.   space   表示   inf   

Description

 文理分科是一件很纠结的事情!(虽然看到这个题目的人肯定都没有纠
结过)
 小P所在的班级要进行文理分科。他的班级可以用一个n*m的矩阵进行
描述,每个格子代表一个同学的座位。每位同学必须从文科和理科中选择
一科。同学们在选择科目的时候会获得一个满意值。满意值按如下的方式
得到:
1.如果第i行第秒J的同学选择了文科,则他将获得art[i][j]的满意值,如
  果选择理科,将得到science[i][j]的满意值。
2.如果第i行第J列的同学选择了文科,并且他相邻(两个格子相邻当且
  仅当它们拥有一条相同的边)的同学全部选择了文科,则他会更开
  心,所以会增加same_art[i][j]的满意值。
3.如果第i行第j列的同学选择了理科,并且他相邻的同学全部选择了理
  科,则增加same_science[i]j[]的满意值。
  小P想知道,大家应该如何选择,才能使所有人的满意值之和最大。请
告诉他这个最大值。

Input

第一行为两个正整数:n,m
接下来n术m个整数,表示art[i][j];
接下来n术m个整数.表示science[i][j];
接下来n术m个整数,表示same_art[i][j];

Output

输出为一个整数,表示最大的满意值之和

Sample Input

3 4
13 2 4 13
7 13 8 12
18 17 0 5

8 13 15 4
11 3 8 11
11 18 6 5

1 2 3 4
4 2 3 2
3 1 0 4

3 2 3 2
0 2 2 1
0 2 4 4

Sample Output

152

HINT

样例说明

1表示选择文科,0表示选择理科,方案如下:

1  0  0  1

0  1  0  0

1  0  0  0
N,M<=100,读入数据均<=500
 
 
这个。。。好像。。。还是一样的最小割啊。。
建议先做:BZOJ2127,也可以看看我的博客:你好!
话说我也够无耻的
那么按照BZOJ2127的思路走。。。他只是从两个点变成了四个点而已啊。。。
那就改成四个点即可
 
代码如下:
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#define INF 999999999
using namespace std;
struct node{
    int x,y,c,next,other;
}a[2100000];int len,last[2100000];
void ins(int x,int y,int c)
{
    int k1,k2;
    k1=++len;
    a[len].x=x;a[len].y=y;a[len].c=c;
    a[len].next=last[x];last[x]=len;
    
    k2=++len;
    a[len].x=y;a[len].y=x;a[len].c=0;
    a[len].next=last[y];last[y]=len;
    
    a[k1].other=k2;
    a[k2].other=k1;
}
int h[510000],head,tail;
int list[510000],st,ed;
bool bt_h()
{
    memset(h,0,sizeof(h));h[st]=1;
    list[1]=st;head=1;tail=2;
    while(head!=tail)
    {
        int x=list[head];
        for(int k=last[x];k;k=a[k].next)
        {
            int y=a[k].y;
            if(h[y]==0&&a[k].c>0)
            {
                h[y]=h[x]+1;
                list[tail++]=y;
            }
        }
        head++;
    }
    if(h[ed]>0)return true;
    return false;
}
int findflow(int x,int f)
{
    if(x==ed)return f;
    int s=0,t;
    for(int k=last[x];k;k=a[k].next)
    {
        int y=a[k].y;
        if(h[y]==h[x]+1&&a[k].c>0&&s<f)
        {
            s+=(t=findflow(y,min(a[k].c,f-s)));
            a[k].c-=t;a[a[k].other].c+=t;
        }
    }
    if(s==0)h[x]=0;
    return s;
}
int n,m;
int sum,ans,d;
int C[110][110],D[110][110];
int main()
{
    scanf("%d%d",&n,&m);
    st=10*n*m+1,ed=st+1;sum=d=0;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            C[i][j]=++d;
    len=0;memset(last,0,sizeof(last));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            int x;
            scanf("%d",&x);sum+=x;
            ins(st,C[i][j],x);
        }
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            int x;
            scanf("%d",&x);sum+=x;
            ins(C[i][j],ed,x);
        }
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            int x;
            scanf("%d",&x);sum+=x;d++;
            ins(st,d,x),ins(d,C[i][j],x);
            if(i<n)ins(d,C[i+1][j],x);
            if(i>1)ins(d,C[i-1][j],x);
            if(j>1)ins(d,C[i][j-1],x);
            if(j<m)ins(d,C[i][j+1],x);
        }
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            int x;
            scanf("%d",&x);sum+=x;d++;
            ins(d,ed,x),ins(C[i][j],d,x);
            if(i<n)ins(C[i+1][j],d,x);
            if(i>1)ins(C[i-1][j],d,x);
            if(j>1)ins(C[i][j-1],d,x);
            if(j<m)ins(C[i][j+1],d,x);
        }
    ans=0;
    while(bt_h()==true)ans+=findflow(st,INF);
    printf("%d\n",sum-ans);
    return 0;
}

by_lmy

 

BZOJ3894: 文理分科

标签:science   正整数   href   online   logs   www.   space   表示   inf   

原文地址:https://www.cnblogs.com/MT-LI/p/8434307.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!