码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5018 Revenge of Fibonacci(数学)

时间:2014-09-19 22:33:06      阅读:263      评论:0      收藏:0      [点我收藏+]

标签:hdu   数学   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5018


Problem Description
In mathematical terms, the sequence Fn of Fibonacci numbers is defined by the recurrence relation
Fn = Fn-1 + Fn-2
with seed values F1 = 1; F2 = 1 (sequence A000045 in OEIS).
---Wikipedia

Today, Fibonacci takes revenge on you. Now the first two elements of Fibonacci sequence has been redefined as A and B. You have to check if C is in the new Fibonacci sequence.
 
Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers A, B and C.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= A, B, C <= 1 000 000 000
 
Output
For each test case, output “Yes” if C is in the new Fibonacci sequence, otherwise “No”.
 
Sample Input
3 2 3 5 2 3 6 2 2 110
 
Sample Output
Yes No Yes
Hint
For the third test case, the new Fibonacci sequence is: 2, 2, 4, 6, 10, 16, 26, 42, 68, 110…
 
Source


代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
typedef __int64 LL;
int main()
{
    LL f[2017];
    int t;
    LL a, b, c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d %I64d %I64d",&a,&b,&c);
        f[0]=a, f[1]=b;
        LL i=2;
        int flag = 0;
        if(a==c || b==c)
        {
            printf("Yes\n");
            continue;
        }
        while(1)
        {
            f[i]=f[i-1]+f[i-2];
            if(f[i] == c)
            {
                flag = 1;
                break;
            }
            if(f[i] > c)
                break;
            i++;
        }
        if(flag)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


HDU 5018 Revenge of Fibonacci(数学)

标签:hdu   数学   

原文地址:http://blog.csdn.net/u012860063/article/details/39403915

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!