码迷,mamicode.com
首页 > 其他好文 > 详细

CF914A Perfect Squares

时间:2018-02-11 12:21:56      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:存在   nbsp   reset   整数   一个   bad   cas   gpo   list   

题意翻译

给定一组有n个整数的数组a1,a2,…,an.找出这组数中的最大非完全平方数。 完全平方数是指有这样的一个数x,存在整数y,使得x=y^2y2 .

输入格式

第一行输入一个单独的整数n(1<=n<=1000 ),n为该组数的数量。 接下来有n个整数,a1,a2,an(-10^6<=a<=10^6) 数据保证至少存在一个整数是非完全平方数。

题目描述

Given an array a_{1},a_{2},...,a_{n}a1?,a2?,...,an? of nn integers, find the largest number in the array that is not a perfect square.

A number xx is said to be a perfect square if there exists an integer yy such that x=y^{2}x=y2 .

输入输出格式

输入格式:

 

The first line contains a single integer nn ( 1<=n<=10001<=n<=1000 ) — the number of elements in the array.

The second line contains nn integers a_{1},a_{2},...,a_{n}a1?,a2?,...,an? ( -10^{6}<=a_{i}<=10^{6}106<=ai?<=106 ) — the elements of the array.

It is guaranteed that at least one element of the array is not a perfect square.

 

输出格式:

 

Print the largest number in the array which is not a perfect square. It is guaranteed that an answer always exists.

 

输入输出样例

输入样例#1: 复制
2
4 2
输出样例#1: 复制
2
输入样例#2: 复制
8
1 2 4 8 16 32 64 576
输出样例#2: 复制
32

说明

In the first sample case, 44 is a perfect square, so the largest number in the array that is not a perfect square is 22 .

技术分享图片

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 1001
using namespace std;
int n;
int num[MAXN];
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&num[i]);
    sort(num+1,num+1+n);
    for(int i=n;i>=1;i--){
        int k=sqrt(num[i]);
        if(k*k!=num[i]){
            cout<<num[i];
            return 0;
        }
    }
}

 

CF914A Perfect Squares

标签:存在   nbsp   reset   整数   一个   bad   cas   gpo   list   

原文地址:https://www.cnblogs.com/cangT-Tlan/p/8440585.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!