码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5018 Revenge of Fibonacci(BestCoder Round #10)

时间:2014-09-20 10:03:57      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:algorithm

Revenge of Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 372    Accepted Submission(s): 177


Problem Description
In mathematical terms, the sequence Fn of Fibonacci numbers is defined by the recurrence relation
Fn = Fn-1 + Fn-2
with seed values F1 = 1; F2 = 1 (sequence A000045 in OEIS).
---Wikipedia

Today, Fibonacci takes revenge on you. Now the first two elements of Fibonacci sequence has been redefined as A and B. You have to check if C is in the new Fibonacci sequence.
 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers A, B and C.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= A, B, C <= 1 000 000 000
 

Output
For each test case, output “Yes” if C is in the new Fibonacci sequence, otherwise “No”.
 

Sample Input
3 2 3 5 2 3 6 2 2 110
 

Sample Output
Yes No Yes
Hint
For the third test case, the new Fibonacci sequence is: 2, 2, 4, 6, 10, 16, 26, 42, 68, 110…
 
水题,fibonacci数不会超过45个就会超范围了,所以最多只有45个有用。

代码:
//0ms
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
long long a[50];
int main()
{
    int t;
    long long c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d",&a[0],&a[1],&c);
        if(a[0]==c||a[1]==c)
        {
            printf("Yes\n");
            continue;
        }
        int sign=0;
        for(int i=2;i<50;i++)
        {
            a[i]=a[i-1]+a[i-2];
            if(a[i]==c)
            {
                sign=1;
                break;
            }
        }
        if(sign)
        printf("Yes\n");
        else
        printf("No\n");
    }
    return 0;
}


hdu 5018 Revenge of Fibonacci(BestCoder Round #10)

标签:algorithm

原文地址:http://blog.csdn.net/caduca/article/details/39429547

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!