码迷,mamicode.com
首页 > 其他好文 > 详细

What Are You Talking About (map)

时间:2018-02-19 16:38:59      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:include   col   利用   cat   length   return   etc   director   new   

Ignatius is so lucky that he met a Martian yesterday. But he didn‘t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him? 

InputThe problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian‘s language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian‘s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can‘t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(‘ ‘), tab(‘\t‘), enter(‘\n‘) and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that‘s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters. 
OutputIn this problem, you have to output the translation of the history book. 
Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i‘m fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i‘m from mars.
i like earth!


        
 

Hint

Huge input, scanf is recommended.
本题相当于翻译句子;
#include<iostream>
#include<map>
#include<string >
using namespace std;
int main()
{
    map <string, string> mp;
    string str, temp;
    cin >> str;
    while (cin >> str && str != "END")
    {
        cin >> temp;
        mp[temp] = str;
    }
    cin >> str;
    getchar();
    while (getline(cin, str) && str != "END")
    {
        string st = "";
        for (int i = 0; i < str.length(); i++)
        {
            if (!isalpha(str[i]))
            {
                map<string, string>::iterator p = mp.find(st);
                if (p == mp.end()) cout << st;
                else cout << mp[st];
                cout << str[i];
                st = "";
            }
            else
                st += str[i];
        }
        cout << endl;
    }
    return 0;
}

 

 利用map<string,string>解决;注意的是放在map中的first,second位置的不同,而引起的find的不同;

灵活应用map

 

What Are You Talking About (map)

标签:include   col   利用   cat   length   return   etc   director   new   

原文地址:https://www.cnblogs.com/kangdong/p/8453883.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!