码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 5023 A Corrupt Mayor's Performance Art(区间修改)

时间:2014-09-20 22:56:29      阅读:258      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   ar   for   div   art   


Problem Description
Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X‘s painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X‘s horse fart(In Chinese English, beating one‘s horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X‘s secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary‘s idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 .... color 30. The wall‘s original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn‘t know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?
 

Input
There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000)

Then M lines follow, each representing an operation. There are two kinds of operations, as described below:

1) P a b c
a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

2) Q a b
a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.
 

Output
For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 ... etc. And this color sequence must be in ascending order.
 

Sample Input
5 10 P 1 2 3 P 2 3 4 Q 2 3 Q 1 3 P 3 5 4 P 1 2 7 Q 1 3 Q 3 4 P 5 5 8 Q 1 5 0 0
 

Sample Output
4 3 4 4 7 4 4 7 8 题意:线段树区间操作 思路:区间修改的懒惰标记代表的意义是:是否被染色了,多个几个剪枝,用一个二进制纪录颜色的种类
#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <algorithm>  
#define lson(x) (x << 1)  
#define rson(x) ((x << 1) | 1)  
using namespace std;  
const int maxn =  1000005;  

struct seg {  
	int col;  
	int flag;  
};   
int sum;

struct segment_tree {  
	seg node[maxn<<2];  

	void update(int pos) {  
		node[pos].col = node[lson(pos)].col | node[rson(pos)].col;  
	}  

	void build(int l, int r, int pos) {  
		node[pos].col = 2;
		node[pos].flag = 1;  
		if (l == r) {  
			return;  
		}  
		int m = l + r >> 1;  
		build(l, m, lson(pos));  
		build(m+1, r, rson(pos));  
	}  

	void push(int pos) {  
		if (node[pos].flag) {  
			node[lson(pos)].col = node[pos].col;
			node[lson(pos)].flag = 1;
			node[rson(pos)].col = node[pos].col;
			node[rson(pos)].flag = 1;
			node[pos].flag = 0;  
		}  
	}  

	void modify(int l, int r, int pos, int x, int y, int z) {  
		if (x <= l && y >= r) {  
			node[pos].col = z;
			node[pos].flag = 1;
			return;  
		}  

		if (node[pos].col == z)
			return;

		push(pos);  

		int m = l + r >> 1;  
		if (x <= m)  
			modify(l, m, lson(pos), x, y, z);  
		if (y > m)  
			modify(m+1, r, rson(pos), x, y, z);  
		update(pos);  
	}  

	void query(int l, int r, int pos, int x, int y) {  
		if (x <= l && y >= r) {
			sum |= node[pos].col;
			return;
		}
		if (node[pos].flag) {
			sum |= node[pos].col;
			return;
		}
		//push(pos);  
		int m = l + r >> 1;  
		if (x <= m)  
			query(l, m, lson(pos), x, y);  
		if (y > m)  
			query(m+1, r, rson(pos), x, y);  
	}  

} tree;  

void cal() {
	int ans = 0;
	int flag = 1;
	while (sum) {
		ans++;
		if (sum & 1) {
			if (flag) {
				printf("%d", ans);
				flag = 0;
			}
			else printf(" %d", ans);
		}
		sum >>= 1;
	}
	printf("\n");
}

int main() {
	int n, m, t;
	while (scanf("%d%d", &n, &m) != EOF && n+m) {
		tree.build(1, n, 1);
		char op[3];
		int a, b, c;
		while (m--) {
			scanf("%s", op);
			if (op[0] == 'P') {
				scanf("%d%d%d", &a, &b, &c);
				if (a > b)
					swap(a, b);
				tree.modify(1, n, 1, a, b, 1<<(c-1));
			}
			else {
				scanf("%d%d", &a, &b);
				if (a > b)
					swap(a, b);
				sum = 0;
				tree.query(1, n, 1, a, b);
				cal();
			}
		}
	}
	return 0;
}


 

HDU - 5023 A Corrupt Mayor's Performance Art(区间修改)

标签:des   style   color   io   os   ar   for   div   art   

原文地址:http://blog.csdn.net/u011345136/article/details/39434679

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!