码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5024 Wang Xifeng's Little Plot (搜索)

时间:2014-09-20 22:36:29      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:搜索

Wang Xifeng‘s Little Plot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 157    Accepted Submission(s): 105



Problem Description
《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the last 40 chapters of the original version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao‘s wife burned the last 40 chapter manuscript for heating because she was desperately poor. This story was proved a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao.

In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn‘t want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu‘s room and Baochai‘s room to be located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai‘s room, and if there was a turn, that turn must be ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu‘s room and Baochai‘s room. Now you can solve this big problem and then become a great redist.
 

Input
The map of Da Guan Yuan is represented by a matrix of characters ‘.‘ and ‘#‘. A ‘.‘ stands for a part of road, and a ‘#‘ stands for other things which one cannot step onto. When standing on a ‘.‘, one can go to adjacent ‘.‘s through 8 directions: north, north-west, west, south-west, south, south-east,east and north-east.

There are several test cases.

For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.

Then the N × N matrix follows.

The input ends with N = 0.
 

Output
For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai‘s rooms. A road‘s length is the number of ‘.‘s it includes. It‘s guaranteed that for any test case, the maximum length is at least 2.
 

Sample Input
3 #.# ##. ..# 3 ... ##. ..# 3 ... ### ..# 3 ... ##. ... 0
 

Sample Output
3 4 3 5
 

题意:

图上有 ‘ . ’ 和 ‘ # ’,其中在 ‘ . ’ 上面可以走动,但有规定:只能朝相邻的8个方向走动,且只能拐一次弯,弯的大小要求恰好为90度。其中 ‘ # ’ 为墙不能走到上面去。求符合以上要求的距离最远的两个点的距离。

其中样例一的解法:(0,1)-> (1,2) -> (2,1)

思路:

以符合要求的点为拐弯点,朝两个垂直的方向走,求出最远的距离。


方向如下图所示:

bubuko.com,布布扣


/************************************************************************
	> File Name: 1003.cpp
	> Author: Bslin
	> Mail: Baoshenglin1994@gmail.com
	> Created Time: 2014年09月20日 星期六 12时43分13秒
 ************************************************************************/

#include <stdio.h>

char map[110][110];
int dir[8][2] = {{0, -1}, {-1, -1}, {-1, 0}, {-1, 1}, {0, 1}, {1, 1}, {1, 0}, {1, -1}};
int n;

bool inmap(int x, int y) {
	if(x >= 0 && x < n && y >= 0 && y < n)
		return true;
	return false;
}

int togo(int x, int y, int d1, int d2) {
	int nowx, nowy, res;
	res = 1;
	nowx = x + dir[d1][0];
	nowy = y + dir[d1][1];
	while(inmap(nowx, nowy) && map[nowx][nowy] == '.') {
		nowx = nowx + dir[d1][0];
		nowy = nowy + dir[d1][1];
		res ++;
	}
	nowx = x + dir[d2][0];
	nowy = y + dir[d2][1];
	while(inmap(nowx, nowy) && map[nowx][nowy] == '.') {
		nowx = nowx + dir[d2][0];
		nowy = nowy + dir[d2][1];
		res ++;
	}
	return res;
}

int dfs(int x, int y) {
	int res, tmp;
	res = 0;
	// 0: l  1: lu  2: u  3: ru  4: r  5: rd  6: d  7: ld
	tmp = togo(x, y, 0, 2);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 0, 6);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 4, 2);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 4, 6);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 1, 3);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 1, 7);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 5, 3);
	if(tmp > res) res = tmp;
	tmp = togo(x, y, 5, 7);
	if(tmp > res) res = tmp;
	return res;
}

int main(int argc, char *argv[]) {
#ifndef ONLINE_JUDGE
	freopen("in", "r", stdin);
#endif
	int i, j;
	int ans, tmp;
	while(~scanf("%d", &n), n) {
		for (i = 0; i < n; ++i) {
			scanf("%s", map[i]);
		}
		ans = 0;
		for (i = 0; i < n; ++i) {
			for (j = 0; j < n; ++j) {
				if(map[i][j] == '.') {
					tmp = dfs(i, j);
					if(tmp > ans) ans = tmp;
				}
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}


HDU 5024 Wang Xifeng's Little Plot (搜索)

标签:搜索

原文地址:http://blog.csdn.net/u012150279/article/details/39434835

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!