码迷,mamicode.com
首页 > 其他好文 > 详细

1030. 完美数列(25)

时间:2018-03-01 13:29:52      阅读:95      评论:0      收藏:0      [点我收藏+]

标签:include   div   输入   gpo   pos   ring   i++   print   正整数   

给定一个正整数数列,和正整数p,设这个数列中的最大值是M,最小值是m,如果M <= m * p,则称这个数列是完美数列。

现在给定参数p和一些正整数,请你从中选择尽可能多的数构成一个完美数列。

输入格式:

输入第一行给出两个正整数N和p,其中N(<= 105)是输入的正整数的个数,p(<= 109)是给定的参数。第二行给出N个正整数,每个数不超过109

输出格式:

在一行中输出最多可以选择多少个数可以用它们组成一个完美数列。

输入样例:

10 8
2 3 20 4 5 1 6 7 8 9

输出样例:

8
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

long long  a[100002];
int cmp( const void *a,const void *b)
{
    return *(int *)a-*(int *)b;
}
int main()
{
    int n,p;
    int i,j;
    int max=1;
    scanf("%d %d",&n,&p);
    for( i=0; i<n; i++)
    {
        scanf("%ld",&a[i]);
    }
    qsort( a,n,sizeof(a[1]),cmp);  //按升序排列
    for( i=0; i<n; i++)
    {
        for( j=i+max; j<n; j++)  
        {
            if( a[i]*p >=a[j])
            {
                if( j-i+1>max)
                    max = j-i+1;
            }
            else break;
        }
    }
    printf("%d",max);
    return 0;
}

 

1030. 完美数列(25)

标签:include   div   输入   gpo   pos   ring   i++   print   正整数   

原文地址:https://www.cnblogs.com/yuxiaoba/p/8487771.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!