码迷,mamicode.com
首页 > 其他好文 > 详细

BZOJ1072: [SCOI2007]排列perm

时间:2018-03-03 12:23:15      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:name   des   mit   type   100%   php   AC   题目   submit   

[Submit][Status][Discuss]

Description

  给一个数字串s和正整数d, 统计s有多少种不同的排列能被d整除(可以有前导0)。例如123434有90种排列能
被2整除,其中末位为2的有30种,末位为4的有60种。

Input

  输入第一行是一个整数T,表示测试数据的个数,以下每行一组s和d,中间用空格隔开。s保证只包含数字0, 1
, 2, 3, 4, 5, 6, 7, 8, 9.

Output

  每个数据仅一行,表示能被d整除的排列的个数。

Sample Input

7
000 1
001 1
1234567890 1
123434 2
1234 7
12345 17
12345678 29

Sample Output

1
3
3628800
90
3
6
1398

HINT

在前三个例子中,排列分别有1, 3, 3628800种,它们都是1的倍数。

【限制】

100%的数据满足:s的长度不超过10, 1<=d<=1000, 1<=T<=15

 
 
一开始波老师说这道题是搜索我不信
10!*15好像。。才几千万,涛老师说过1s可以跑一亿的。。。
那就爆搜吧,我上网查了一个c++自带全排列函数
两个版本
 
爆搜:
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
int T;
char st[31];
int d,n;
int a[31];int sum;
inline void dfs(int x,ll k)
{
    if(x>n)
    {if(k%d==0)sum++;
    return ;}
    for(int i=0;i<=9;i++)
        if(a[i]>0)
        {
            a[i]--;
            dfs(x+1,k*10+i);
            a[i]++;
        }
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        memset(a,0,sizeof(a));
        scanf("%s%d",st+1,&d);
        for(int i=1;i<=(n=strlen(st+1));i++)
            a[st[i]-0]++;
        sum=0;
        dfs(1,0);
        printf("%d\n",sum);
    }
    return 0;
}

函数:

#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
int T;
char st[31];
int d;
int a[31];
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%s%d",st+1,&d);
        for(int i=1;i<=(n=strlen(st+1));i++)
        {
            a[i]=st[i]-0;
        }
        int sum=0;
        sort(a+1,a+1+n);
        do
        {
            ll ans=0;
            for(int i=1;i<=n;i++)
                ans*=10,ans+=a[i];
            if(ans%d==0)sum++;
        }while(next_permutation(a+1,a+1+n)==true);
        printf("%d\n",sum);
    }
    return 0;
}

by_lmy

 

BZOJ1072: [SCOI2007]排列perm

标签:name   des   mit   type   100%   php   AC   题目   submit   

原文地址:https://www.cnblogs.com/MT-LI/p/8495901.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!