码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 1944 Tree Recovery (二叉树)

时间:2014-09-21 21:55:21      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   递归   二叉树   

Tree Recovery

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 

This is an example of one of her creations:

         D
        / \
       /   \
      B     E
     / \     \
    /   \     \
   A     C     G
              /
             /
            F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 

However, doing the reconstruction by hand, soon turned out to be tedious. 

So now she asks you to write a program that does the job for her!


Input

The input will contain one or more test cases. 

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.


Output

For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).


Sample Input

DBACEGF ABCDEFG
BCAD CBAD


Sample Output

ACBFGED
CDAB

这道题和之前做的重建二叉树 思路基本一致,那道题是已知中序和后序遍历,求前序遍历,这道题就是已知前序遍历和中序遍历,求后序遍历,由前序遍历可以得到这棵树的根节点,由中序遍历把这棵树分成两部分,然后再进行递归求解;

下面是代码:

#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
struct node
{
    char value;
    node *lchild,*rchild;//左右子树
};
node *newnode(char c)
{
    node *p;
    p=(node *)malloc(sizeof(node));
    p->value=c;
    p->lchild=p->rchild=NULL;
    return p;
}
node *rebulid(char *pre,char *in,int n)
{
    if(n==0) return NULL;
    int l_len,r_len,i;
    char s=pre[0];
    node *root=newnode(s);
    for(i=0;i<n&&in[i]!=s;i++);
    l_len=i;
    r_len=n-i-1;
    if(l_len>0) root->lchild=rebulid(pre+1,in,l_len);//递归求解
    if(r_len>0) root->rchild=rebulid(pre+l_len+1,in+l_len+1,r_len);
    return root;
}
void postorder(node *p)
{
    if(p==NULL) return;
    postorder(p->lchild);
    postorder(p->rchild);
    printf("%c",p->value);
}
int main()
{
    char preorder[30],inorder[30];
    while(scanf("%s%s",preorder,inorder)!=EOF)
    {
        node *root=rebulid(preorder,inorder,strlen(preorder));
        postorder(root);
        printf("\n");
    }
    return 0;
}


zoj 1944 Tree Recovery (二叉树)

标签:acm   算法   递归   二叉树   

原文地址:http://blog.csdn.net/whjkm/article/details/39456183

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!