码迷,mamicode.com
首页 > 其他好文 > 详细

一只小蜜蜂...

时间:2018-03-04 16:09:38      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:blog   data   static   tle   main   rip   sample   can   output   

Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。
技术分享图片
 

 

Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。
 

 

Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
 

 

Sample Input
2 1 2 3 6
 

 

Sample Output
1 3
 
AC代码:
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        while (n-- > 0) {
            long[] arr = new long[51];
            arr[0] = 1;
            arr[1] = 1;
            for (int i = 2; i < arr.length; i++) {
                arr[i] = arr[i - 1] + arr[i - 2];
            }
            int a = sc.nextInt();
            int b = sc.nextInt();
            int c = b-a;
            System.out.println(arr[c]);
        }

    }
}

  

一只小蜜蜂...

标签:blog   data   static   tle   main   rip   sample   can   output   

原文地址:https://www.cnblogs.com/ixummer/p/8504618.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!