码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 10474 - Where is the Marble?

时间:2014-09-22 01:04:21      阅读:477      评论:0      收藏:0      [点我收藏+]

标签:排序   stl   sort   

Where is the Marble?

  Where is the Marble? 

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it‘s your chance to play as Raju. Being the smart kid, you‘d be taking the favor of a computer. But don‘t underestimate Meena, she had written a program to keep track how much time you‘re taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

Input 

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles andQ the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

Output 

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

  • `x found at y‘, if the first marble with number x was found at position y. Positions are numbered 1, 2,..., N.
  • `x not found‘, if the marble with number x is not present.

Look at the output for sample input for details.

Sample Input 

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

Sample Output 

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

先排序在用lower_bound查找,sort函数+lower_bound

#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=10000;
int main()
{
	int a[MAXN],n,q,x,sum=0;
	while (scanf("%d%d",&n,&q)&&n)
	{
		
		printf("CASE# %d:\n",++sum);
		for (int i=0;i<n;i++)
			scanf("%d",&a[i]);
		sort(a,a+n);
		while(q--)
		{
			scanf("%d",&x);
			int p=lower_bound(a,a+n,x)-a;
			if(a[p]==x)
				printf("%d found at %d \n",x,p+1);
			else
				printf("%d not found\n",x);
		}
	}
	return 0;
}


UVA 10474 - Where is the Marble?

标签:排序   stl   sort   

原文地址:http://blog.csdn.net/u014492609/article/details/39456909

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!