码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj Dinner

时间:2018-03-07 21:50:34      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:mit   post   blog   one   ring   amp   isp   from   output   

Dinner

时间限制:100 ms  |  内存限制:65535 KB
难度:1
 
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
 
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
提示
The tableware only contains: bowl, knife, fork and chopsticks.

#include <iostream>

using namespace std;

int main()
{
int n;
string s[10];
while(cin>>n)
{
for(int i=0;i<n;i++)
{
cin>>s[i];
if(s[i]=="fork"||s[i]=="chopsticks"||s[i]=="bowl"||s[i]=="knife")
cout<<s[i]<<" ";
}
cout<<endl;
}
return 0;
}

 

nyoj Dinner

标签:mit   post   blog   one   ring   amp   isp   from   output   

原文地址:https://www.cnblogs.com/tianzeng/p/8524888.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!