码迷,mamicode.com
首页 > 其他好文 > 详细

1036. Boys vs Girls (25)

时间:2018-03-09 14:08:24      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:cat   clu   positive   for   end   you   ike   cstring   specific   

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student‘s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

 

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA
#include<cstdio>
#include<cstring> 
struct student{
    char name[15];
    char id[15];
    int score;
}M,F,temp;
void init(){
    M.score = 101;
    F.score = -1;
}
int main(){
    init();
    int n;
    char gender;
    scanf("%d",&n);
    
    for(int i = 0; i < n; i++){
        scanf("%s %c %s %d",temp.name,&gender,temp.id,&temp.score);
        if(gender == M && M.score > temp.score) M = temp; // 男孩分数低,设置最高,大于输入,赋值 
        else if(gender == F && F.score < temp.score) F = temp; 
    }
    if(F.score == -1)printf("Absent\n");
    else printf("%s %s\n",F.name,F.id);
    if(M.score == 101) printf("Absent\n");
    else printf("%s %s\n",M.name,M.id);
    if(F.score == -1 || M.score == 101) printf("NA\n");
    else printf("%d\n",F.score - M.score);
    
    return 0;
}

 

1036. Boys vs Girls (25)

标签:cat   clu   positive   for   end   you   ike   cstring   specific   

原文地址:https://www.cnblogs.com/wanghao-boke/p/8533289.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!