码迷,mamicode.com
首页 > 其他好文 > 详细

L - Large Division (大数, 同余)

时间:2018-03-09 20:32:58      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:otherwise   AC   printf   bsp   details   char   event   cli   net   

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print ‘divisible‘ if a is divisible by b. Otherwise print ‘not divisible‘.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

 

题解:用一个数组来存储大数,运用同余定理

(a*b)%c=(a%c*b%c)%c;

判断最后的余数是不是为零。注意:要用到long long型

关于同余定理

AC代码

技术分享图片
#include<stdio.h>
#include<string.h>

int main()
{
    int n;
    char a[230];
    int b, num = 0;
    long long sum;
    scanf("%d", &n);
    while(n--)
    {
        sum = 0;
        scanf("%s %d", a, &b);
        int len = strlen(a);
        for(int i = 0; i < len; i++)
        {
            if(a[i] != -)
            {
                sum = (sum*10 + a[i] - 0) % b;
            }
        }
        num++;
        if(sum == 0)
            printf("Case %d: divisible\n", num);
        else
            printf("Case %d: not divisible\n", num);
    }

    return 0;
}
View Code

 

L - Large Division (大数, 同余)

标签:otherwise   AC   printf   bsp   details   char   event   cli   net   

原文地址:https://www.cnblogs.com/ruruozhenhao/p/8535514.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!