Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
题意
在海岸线上部署雷达,雷达的探测范围是半径为d的圆。求最少需要部署多少雷达可以覆盖全部的小岛。
题解
区间贪心,先按照左端点排序。然后依次对右端点进行比较。
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1005;
typedef long long LL;
inline LL read()
{
LL x=0,f=1;char ch=getchar();
while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
return x*f;
}
struct node
{
double l,r;
bool operator < (const node b)const
{
return l<b.l;
}
}seg[maxn];
int main()
{
int n,d;
int cnt=1;
while(cin>>n>>d)
{
if(!(n||d))
break;
int x,y;
bool flag=false;
for(int i=0;i<n;i++)
{
cin>>x>>y;
if(y>d)
flag=true;
double tmp=sqrt(d*d-y*y);
seg[i].l=x-tmp,seg[i].r=x+tmp;
}
cout<<"Case "<<cnt++<<": ";
if(flag)
{
cout<<"-1"<<endl;
continue;
}
sort(seg,seg+n);
node line=seg[0];
int ans=1;
for(int i=1;i<n;i++)
{
if(seg[i].l>line.r)
{
ans++;
line=seg[i];
}
else if(seg[i].r<line.r)
line=seg[i];
}
cout<<ans<<endl;
}
return 0;
}