码迷,mamicode.com
首页 > 其他好文 > 详细

1027. Colors in Mars (20)

时间:2018-03-10 20:28:15      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:amp   ima   sed   val   log   contains   cst   span   follow   

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

 

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input

15 43 71

Sample Output

#123456
#include<cstdio>
char radix[14] = {
    0,1,2,3,4,5,6,7,8,9,A,B,C
};  //const int 也通过? 

int main(){
    int r,g,b;
     scanf("%d%d%d",&r,&g,&b);
     printf("#");
     printf("%c%c",radix[r/13],radix[r%13]); //进制转化 
     printf("%c%c",radix[g/13],radix[g%13]); //不能是%d 
     printf("%c%c",radix[b/13],radix[b%13]);
   
 return 0;
}

 

1027. Colors in Mars (20)

标签:amp   ima   sed   val   log   contains   cst   span   follow   

原文地址:https://www.cnblogs.com/wanghao-boke/p/8541540.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!