码迷,mamicode.com
首页 > 其他好文 > 详细

1058. A+B in Hogwarts (20)

时间:2018-03-10 20:30:46      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:bsp   clu   long   sample   integer   数组   silver   where   art   

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it‘s easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28
#include<cstdio>
const int S = 29;
const int G = 29*17; 

int main(){ 
    int a1,a2,a3,b1,b2,b3; //int 数组有溢出,需要用long long 
    scanf("%d.%d.%d %d.%d.%d",&a1,&a2,&a3,&b1,&b2,&b3);
    int sum = (a1+b1)*G+(b2+a2)*S+a3+b3;
    printf("%d.%d.%d",sum/G,sum%G/S,sum%S);
    
    return 0;
}
#include<cstdio>

int main(){ 
    int a[3],b[3],c[3]; //int 数组有溢出,需要用long long 
    int carry = 0;
    scanf("%d.%d.%d %d.%d.%d",&a[0],&a[1],&a[2],&b[0],&b[1],&b[2]);
    c[2] = (a[2] + b[2]) % 29;
    carry = (a[2] + b[2]) / 29;
    c[1] = (a[1] + b[1] + carry) % 17;
    carry = (a[1] + b[1] + carry) / 17;
    c[0] = (a[0] + b[0] + carry);
    printf("%d.%d.%d",c[0],c[1],c[2]);
    
    return 0;
}

 

1058. A+B in Hogwarts (20)

标签:bsp   clu   long   sample   integer   数组   silver   where   art   

原文地址:https://www.cnblogs.com/wanghao-boke/p/8541602.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!