码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1348 Period(KMP)

时间:2018-03-12 22:55:33      阅读:238      评论:0      收藏:0      [点我收藏+]

标签:mission   nes   wan   amp   nta   ==   ext   post   inf   

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10419    Accepted Submission(s): 4940


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

 

Sample Input
3 aaa 12 aabaabaabaab 0
 

 

Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

简单题,既然next[I]表示LBorderi,那么该串是重复串,首先要符合他是个周期串,即next[i]*2>i,其次如果其为重复串,那么除去最大匹后缀后的部分和除去最大匹配前缀的部分应相同,并且他们的长度整除i。事实上前一个条件包含在后一个条件里,因为能整除说明他们皆为该重复串的一个基串,那么他们必相同(有点绕,你自己动手证明下,从周期串的角度)。因此做法就很显而易见了。

技术分享图片
#include<bits/stdc++.h>
#define clr(x) memset(x,0,sizeof(x))
#define clr_1(x) memset(x,-1,sizeof(x))
#define LL long long
#define mod 1000000007
#define INF 0x3f3f3f3f
#define next nexted
using namespace std;
const int N=1e6+10;
char s[N];
int next[N];
int n,T;
void getnext(int n,char *s)
{
    next[0]=next[1]=0;
    int j=0;
    int len=n;
    for(int i=1;i<len;i++)
    {
        while(j && s[i]!=s[j]) j=next[j];
        if(s[j]==s[i]) j++;
        next[i+1]=j;
    }
    return ;
}
int main()
{
    T=0;
    while(scanf("%d",&n)==1 && n)
    {
        scanf("%s",s);
        getnext(n,s);
        printf("Test case #%d\n",++T);
        for(int i=1;i<=n;i++)
        {
            if(next[i]*2>=i)
            {
                if(i%(i-next[i])==0)
                    printf("%d %d\n",i,i/(i-next[i]));
            }
        }
        printf("\n");
    }
    return 0;
}
View Code

 

poj 1348 Period(KMP)

标签:mission   nes   wan   amp   nta   ==   ext   post   inf   

原文地址:https://www.cnblogs.com/wujiechao/p/8552201.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!