码迷,mamicode.com
首页 > 其他好文 > 详细

1035. Password (20)

时间:2018-03-14 10:11:43      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:name   sample   [1]   generate   ecif   cas   and   scan   pat   

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

 

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified
import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int n=Integer.parseInt(sc.nextLine().trim());
		int count=0;
		String name[]=new String[n];
		String password[]=new String[n];
		for(int i=0;i<n;i++){
			String s=sc.nextLine().trim();
			String nam=s.split(" ")[0];
			String pas=s.split(" ")[1];
			if(pas.contains("1")||pas.contains("O")||pas.contains("0")||pas.contains("l")){
				
				pas=pas.replace(‘O‘, ‘o‘);
				pas=pas.replace(‘1‘, ‘@‘);
				pas=pas.replace(‘0‘, ‘%‘);
				pas=pas.replace(‘l‘, ‘L‘);
				name[count]=nam;
				password[count]=pas;
				count++;
			}
		}
		if(count==0&&n==1){
			System.out.println("There is "+n+" account and no account is modified");
			return;
			
		}
		if(count==0&&n>1){
			System.out.println("There are "+n+" accounts and no account is modified");
			return;
		}
		
		
		else{
			System.out.println(count);
			for(int i=0;i<count;i++){
				System.out.println(name[i]+" "+password[i]);
			}
		}
	}
}

  

1035. Password (20)

标签:name   sample   [1]   generate   ecif   cas   and   scan   pat   

原文地址:https://www.cnblogs.com/fangxiaoneng/p/8565165.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!