码迷,mamicode.com
首页 > 其他好文 > 详细

【TOJ 3136】Ubiquitous Religions

时间:2018-03-14 18:03:52      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:ble   you   div   ssi   line   pair   pre   max   comm   

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample output

Case 1: 1
Case 2: 7

Tip

Huge input, scanf is recommended.
Meaning of question
一共n个人,编号为1~n,每个人最多可以信奉1个宗教,给出m对学生,每对学生的宗教相同,问n个人最多有几个不同的宗教
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int top[50005],n,m;
int find(int r)
{
    if(top[r]!=r)
    top[r]=find(top[r]);             //压缩路径
    return top[r];
}
int join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)                       //若两人之前无关系,宗教总数-1
    {
        n--;
        top[fx]=fy;
    }
}
int init(int n)
{
    int i;
    for(i=1;i<=n;i++)
        top[i]=i;
}
int main()
{
    int i,x,y,s=0;
    while(~scanf("%d%d",&n,&m),n||m)
    {
        s++;
        init(n);                     //初始化
        while(m--)
        {
            scanf("%d%d",&x,&y);
            join(x,y);
        }
        printf("Case %d: %d\n",s,n);
    }
    return 0;
}

【TOJ 3136】Ubiquitous Religions

标签:ble   you   div   ssi   line   pair   pre   max   comm   

原文地址:https://www.cnblogs.com/kannyi/p/8568838.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!