码迷,mamicode.com
首页 > 其他好文 > 详细

poj2828 Buy Tickets (线段树 插队问题)

时间:2018-03-16 21:33:42      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:china   outside   next   ice   iostream   update   color   output   plm   

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 22097   Accepted: 10834

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

技术分享图片

Source

实现代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mid int m = (l + r)>>1
const int M = 2e5+10;
ll sum[M<<2],a[M<<2],b[M<<2],md,ans[M<<2];

void pushup(int rt){
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}

void build(int l,int r,int rt){
    if(l == r){
        sum[rt] = 1;
        return ;
    }
    mid;
    build(lson);
    build(rson);
    pushup(rt);
}

void update(int p,int c,int l,int r,int rt){
    if(l == r){
        ans[l] = c;
        sum[rt]--;
        return ;
    }
    mid;
    if(sum[rt<<1] >= p) update(p,c,lson);
    else update(p-sum[rt<<1],c,rson);
    pushup(rt);
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
    memset(ans,0,sizeof(ans));
    build(1,n,1);
    for(int i = 0;i < n;i ++){
        scanf("%d%d",&a[i],&b[i]);
    }
    for(int i = n-1;i >= 0;i --){
        update(a[i]+1,b[i],1,n,1);
    }
    for(int i = 1;i < n;i ++)
        printf("%d ",ans[i]);
    printf("%d\n",ans[n]);
    }
    return 0;
}

 

poj2828 Buy Tickets (线段树 插队问题)

标签:china   outside   next   ice   iostream   update   color   output   plm   

原文地址:https://www.cnblogs.com/kls123/p/8585153.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!