码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4006 The kth great number,set,priority_queue

时间:2014-09-22 19:12:13      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:style   io   os   ar   strong   for   sp   on   c   

The kth great number

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
Output

The output consists of one integer representing the largest number of islands that all lie on one line. 


Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
Sample Output
1
2
3

Hint
Xiao  Ming  won‘t  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).

 


用set或者priority_queue维护长度为k从小到大有序的序列,每次查询的时候首元素即为所求。


#include <cstdio>
#include <set>
#include <map>
#include <vector>
#include <iostream>
using namespace std;

multiset<int> ms;

int main()
{
    int n, k, x;
    char ch[10];
    while(~scanf("%d%d", &n, &k)) {
        ms.clear();
        while(n--) {
            scanf("%s", ch);
            if(ch[0]=='I') {
                scanf("%d",&x);
                ms.insert(x);
                if(ms.size()>k) {
                    ms.erase(ms.begin());
                }
            } else {
                printf("%d\n", *ms.begin());
            }
        }
    }
    return 0;
}



#include <cstdio>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <iostream>
using namespace std;

priority_queue<int,vector<int>, greater<int> > pq;

int main()
{
    int n, k, x;
    char ch[10];
    while(~scanf("%d%d", &n, &k)) {
        while(!pq.empty()) pq.pop();
        while(n--) {
            scanf("%s", ch);
            if(ch[0]=='I') {
                scanf("%d",&x);
                pq.push(x);
                if(pq.size()>k) {
                    pq.pop();
                }
            } else {
                printf("%d\n", pq.top());
            }
        }
    }
    return 0;
}


hdu 4006 The kth great number,set,priority_queue

标签:style   io   os   ar   strong   for   sp   on   c   

原文地址:http://blog.csdn.net/yew1eb/article/details/39479243

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!