码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5038 Grade(水)

时间:2014-09-22 19:30:13      阅读:279      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   java   ar   

题目链接:

思路:
这个题目应该随便怎么搞都可以,我说一下我的思路,可以根据题目的数据计算出价值的取值范围为0~10000,所以用一个1w的数组表示数组,下标代表价值,数组值代表数目,
然后这个题目要特判一下全是一样的值的情况。

题目:

Grade

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 297    Accepted Submission(s): 167


Problem Description
Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is 

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
 

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
 

Output
For each test case, output 2 lines.

The first line contains "Case #x:", where x is the case number (starting from 1) 

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
 

Sample Input
3 6 100 100 100 99 98 101 6 100 100 100 99 99 101 6 100 100 98 99 99 97
 

Sample Output
Case #1: 10000 Case #2: Bad Mushroom Case #3: 9999 10000
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5041 5040 5039 5037 5036 
 


代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<vector>
#include<cmath>
#include<string>
#include<queue>
#define eps 1e-9
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;

const int maxn=10000+10;


int a[maxn],n,b[maxn];

int main()
{
    int t,val,temp,cnt,max_,cas=1,num,star,first,second;
    scanf("%d",&t);
    while(t--)
    {
       int ok=0;
       scanf("%d",&n);
       num=0;
       max_=-1;
       cnt=1;
       memset(a,0,sizeof(a));
       memset(b,0,sizeof(b));
       for(int i=1;i<=n;i++)
       {
           scanf("%d",&temp);
           val=10000-(100-temp)*(100-temp);
           a[val]++;
           if(i==1)
               first=val;
           else
           {
               if(first!=val)
                 ok=1;
           }
        }
        printf("Case #%d:\n",cas++);
        if(ok==0)
            {
                printf("%d\n",first);
                continue;
            }
       for(int i=0;;i++)
          if(a[i]>0)
           {
               second=i;
               star=a[i];
               break;
           }
       for(int i=second;i<=10001;i++)
       {
           if(a[i]>0)
            {
                if(a[i]>max_)
                   max_=a[i];
                if(a[i]!=star)
                   cnt++;
            }
       }
       if(cnt==1)
           printf("Bad Mushroom\n");
        else
        {
           for(int i=0;i<=10001;i++)
            {
               if(a[i]==max_)
                  b[++num]=i;
            }
             for(int i=1;i<num;i++)
                printf("%d ",b[i]);
            printf("%d\n",b[num]);
        }
    }
    return 0;
}


hdu 5038 Grade(水)

标签:des   style   blog   http   color   io   os   java   ar   

原文地址:http://blog.csdn.net/u014303647/article/details/39479033

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!