码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2528 线段树+特殊离散化

时间:2018-03-17 16:51:29      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:bsp   describe   cup   decide   str   one   rate   style   下标   

Mayor‘s posters
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 51098   Accepted: 14788

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters‘ size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 
技术分享图片

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

思路:
很经典的题。。线段树+离散化,难点主要在于需要用特殊的离散化方法,一般的离散化方法会出错
比如下面这串数据
3
1-10
1-4
6-10
一般离散化后就会变成 a[0] = 1;a[1] = 4;a[2] = 6;a[3]= 10;
离散化将把这些数据的下标作为值放进线段树处理后就会成为:
0 - 3 为1颜色
0 - 1 为2颜色
2 - 3 为3颜色
最后只存在两种颜色
但正确的过程应该是:
1 - 10 为1颜色
1 - 4 为2颜色
6 - 10 为3颜色
最后存在三种颜色

实现代码:
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mid int m = (l + r) >> 1
const int M = 2e5+10;
int col[M<<2],Hash[M<<2],cnt,a[M],l[M],r[M];
void pushdown(int rt){
    if(col[rt]!=-1){
        col[rt<<1] = col[rt<<1|1] = col[rt];
        col[rt] = -1;
    }
}

void update(int L,int R,int c,int l,int r,int rt){
    if(L <= l&&R >= r){
        col[rt] = c;
        return ;
    }
    pushdown(rt);
    mid;
    if(L <= m) update(L,R,c,lson);
    if(R > m) update(L,R,c,rson);
}

void query(int l,int r,int rt){
    if(col[rt]!=-1){
        if(Hash[col[rt]]==0) cnt++;
        Hash[col[rt]] = 1;
        return ;
    }
    if(l == r) return;
    mid;
    query(lson);
    query(rson);
}

int bin(int key,int n,int a[]){
    int l = 0,r = n-1;
    while(l <= r){
        mid;
        if(a[m] == key) return m;
        else if(a[m] < key) l = m+1;
        else r = m-1;
     }
     return -1;
}
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0); cout.tie(0);
    int t,n;
    cin>>t;
    while(t--){
        cin>>n;
        memset(col,-1,sizeof(col));
        memset(Hash,0,sizeof(Hash));
        int nn = 0;
        cnt = 0;
        for(int i = 0;i < n;i++){
            cin>>l[i]>>r[i];
            a[nn++] = l[i];a[nn++] = r[i];
        }
        sort(a,a+nn);
        int m = 1;
        for(int i = 1;i < nn;i ++){
            if(a[i]!=a[i-1]) a[m++] = a[i];
        }
        for(int i = m-1;i > 0;i --){
            if(a[i]!=a[i-1]+1) a[m++] = a[i] + 1;
        }
        sort(a,a+m);
        for(int i = 0;i < n;i ++){
            int li = bin(l[i],m,a);
            int ri = bin(r[i],m,a);
            update(li,ri,i,0,m,1);
        }
        query(0,m,1);
        cout<<cnt<<endl;
    }
}

 

poj 2528 线段树+特殊离散化

标签:bsp   describe   cup   decide   str   one   rate   style   下标   

原文地址:https://www.cnblogs.com/kls123/p/8590602.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!