码迷,mamicode.com
首页 > 其他好文 > 详细

acm_icpc网络赛第五站:北京赛区

时间:2014-09-22 23:28:13      阅读:246      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   java   ar   strong   for   

北京嘛,没什么好说的。。实验室貌似没出线的。。哎 就一道水题还被我英语给坑了。。

哈希一水:

Grade

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 344    Accepted Submission(s): 195


Problem Description
Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is 

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
 

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
 

Output
For each test case, output 2 lines.

The first line contains "Case #x:", where x is the case number (starting from 1) 

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
 

Sample Input
3 6 100 100 100 99 98 101 6 100 100 100 99 99 101 6 100 100 98 99 99 97
 

Sample Output
Case #1: 10000 Case #2: Bad Mushroom Case #3: 9999 10000


#include <iostream>
#include <algorithm>
#include <queue>
#include <cstring>
#include <cstdio>
#include <vector>
#include <set>
#include <map>
using namespace std;
int h[100010],ans[100010];
int main()
{
    int T,n,x,cas=1;
    scanf("%d",&T);
    while(T--)
    {
    	memset(h,0,sizeof(h));
    	scanf("%d",&n);
    	int MAX=0,p=0;
    	for(int i=0;i<n;i++)
		{
			scanf("%d",&x);
			int s=10000-(100-x)*(100-x);
			h[s]++;
			if(h[s]>MAX)
				MAX=h[s];
		}
		for(int i=0;i<10010;i++)
		{
			if(h[i]&&h[i]==MAX)
			{
				MAX=h[i];
				ans[p++]=i;
			}
		}
			printf("Case #%d:\n",cas++);
			if(p==1)
			{
				printf("%d\n",ans[0]);
				continue;
			}
			if(p*MAX==n)
			{
				printf("Bad Mushroom\n");
				continue;
			}
			sort(ans,ans+p);
			for(int i=0;i<p;i++)
				if(i!=p-1)
				printf("%d ",ans[i]);
			    else
				printf("%d\n",ans[i]);
    }
	return 0;
}




acm_icpc网络赛第五站:北京赛区

标签:des   style   color   io   os   java   ar   strong   for   

原文地址:http://blog.csdn.net/qq_16255321/article/details/39481671

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!