码迷,mamicode.com
首页 > 其他好文 > 详细

LightOJ 1214(Large Division)

时间:2018-03-21 21:59:25      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:you   ide   printf   none   its   scanf   lead   body   splay   

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.


Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print ‘divisible‘ if a is divisible by b. Otherwise print ‘not divisible‘.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

 

分析:大数取余。

技术分享图片
#include<cstdio>
char s[300];
int main()
{
    int T,cas=0;long long b;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%lld",s,&b);
        if(b<0) b=-b;
        int i=0;
        if(s[i]==-) i++;
        long long res=0;
        while(s[i])
            res=(res*10+(s[i++]-0))%b;
        if(res==0) printf("Case %d: divisible\n",++cas);
        else printf("Case %d: not divisible\n",++cas);
    }
    return 0;
}
View Code

 

 

 

 

LightOJ 1214(Large Division)

标签:you   ide   printf   none   its   scanf   lead   body   splay   

原文地址:https://www.cnblogs.com/ACRykl/p/8619771.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!