码迷,mamicode.com
首页 > 其他好文 > 详细

Full Binary Tree

时间:2018-03-22 23:08:10      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:bin   ini   ret   ide   示例   most   gpo   scan   fine   

Time Limit: 2000MS Memory limit: 65536K
题目描述
In computer science, a binary tree is a tree data structure in which each node has at most two children. Consider an infinite full binary tree (each node has two children except the leaf nodes) defined as follows. For a node labelled v its left child will be labelled 2?*?v and its right child will be labelled 2?*?v?+?1. The root is labelled as 1.

You are given n queries of the form i,?j. For each query, you have to print the length of the shortest path between node labelled i and node labelled j.

输入
First line contains n(1?≤?n?≤?10^5), the number of queries. Each query consists of two space separated integers i and j(1?≤?i,?j?≤?10^9) in one line.

输出
For each query, print the required answer in one line.

示例输入

5
1 2
2 3
4 3
1024 2048
3214567 9998877

示例输出

1
2
3
1
44


来源

2014年山东省第五届ACM大学生程序设计竞赛

 

大神的代码竟然是这样:

#include <stdio.h>  
int main()  
{  
    int i,j;  
    int n,m;  
    int T;  
    scanf("%d",&T);  
    while(T--)  
    {  
        int count=0;  
        scanf("%d %d",&n,&m);  
        while(n!=m)  
        {  
            if(n>m)  
                n/=2;  
            else  
                m/=2;  
            count++;  
        }  
        printf("%d\n",count);  
    }  
    return 0;  
}  

 

佩服佩服 

 

Full Binary Tree

标签:bin   ini   ret   ide   示例   most   gpo   scan   fine   

原文地址:https://www.cnblogs.com/coder-tcm/p/8627478.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!