码迷,mamicode.com
首页 > 其他好文 > 详细

qianghongbao

时间:2018-03-25 17:00:32      阅读:253      评论:0      收藏:0      [点我收藏+]

标签:没有   view   tom   ace   class   list   clu   namespace   输出   

没有人没抢过红包吧…… 这里给出N个人之间互相发红包、抢红包的记录,请你统计一下他们抢红包的收获。

输入格式:

输入第一行给出一个正整数N(10?4??),即参与发红包和抢红包的总人数,则这些人从1到N编号。随后N行,第i行给出编号为i的人发红包的记录,格式如下:

KN?1??P?1???N?K??P?K??

其中K(0K20)是发出去的红包个数,N?i??是抢到红包的人的编号,P?i??(>0)是其抢到的红包金额(以分为单位)。注意:对于同一个人发出的红包,每人最多只能抢1次,不能重复抢。

输出格式:

按照收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。每个人的信息占一行,两数字间有1个空格。如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。

输入样例:

10
3 2 22 10 58 8 125
5 1 345 3 211 5 233 7 13 8 101
1 7 8800
2 1 1000 2 1000
2 4 250 10 320
6 5 11 9 22 8 33 7 44 10 55 4 2
1 3 8800
2 1 23 2 123
1 8 250
4 2 121 4 516 7 112 9 10

输出样例:

1 11.63
2 3.63
8 3.63
3 2.11
7 1.69
6 -1.67
9 -2.18
10 -3.26
5 -3.26
4 -12.32

 

#include<bits/stdc++.h>
#define p pair<int,int>
using namespace std;
map<int,int> mg;
bool cmp(p a,p b)
{
    if(a.second>b.second)
    return true;
    if(a.second==b.second)
    {
        if(mg[a.first]>mg[b.first])
        return true;
        if(mg[a.first]==mg[b.first])
        {
            if(a.first<b.first)
            return true;
        }
    }
    return false;
}
int main()
{
    int n,a,b,vis[100005];
    cin>>n;
    map<int,int> ma;
    map<int,int>::iterator it;
    vector<p>v;
    vector<p>::iterator itt;
    int k;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&k);
        memset(vis,0,sizeof(vis));
        while(k--)
        {
            scanf("%d",&a);
            scanf("%d",&b);
            if(vis[a]==0)
            {
                vis[a]=1;
                mg[a]++;
                ma[a]+=b;
                ma[i]-=b;
            }
        }
    }
    for(it=ma.begin();it!=ma.end();it++)
    {
        v.push_back(p(it->first,it->second));
    }
    sort(v.begin(),v.end(),cmp);
    for(itt=v.begin();itt!=v.end();itt++)
    {
        cout<<itt->first<<" "<<itt->second*1.0/100<<endl;
    }
    return 0;
}

 

qianghongbao

标签:没有   view   tom   ace   class   list   clu   namespace   输出   

原文地址:https://www.cnblogs.com/kannyi/p/8645292.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!