码迷,mamicode.com
首页 > 其他好文 > 详细

1050. String Subtraction (20)

时间:2018-03-26 10:54:26      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:ace   tee   main   div   case   ==   action   pre   als   

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.
#include<cstdio>
#include<cstring>
const int maxn = 10010;
char a[maxn],b[maxn];
bool hashTable[128] = {false};
int main(){
    gets(a);
    gets(b);
    int len1 = strlen(a);
    int len2 = strlen(b);
    for(int i = 0; i < len2; i++){
        hashTable[b[i]] = true;
    }
    for(int i = 0; i < len1; i++){
        if(hashTable[a[i]] == false){
            printf("%c",a[i]);
        }
    }
    return 0;
}

 

1050. String Subtraction (20)

标签:ace   tee   main   div   case   ==   action   pre   als   

原文地址:https://www.cnblogs.com/wanghao-boke/p/8648997.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!