码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5543(Pick The Sticks) 01背包

时间:2018-03-28 00:03:31      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:arm   too   cond   led   overlap   bsp   outside   cep   log   

Pick The Sticks

Time Limit: 15000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2540    Accepted Submission(s): 850


Problem Description
The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he‘s clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an L length segment. And the gold sticks as segments too. There were many gold sticks with different length ai and value vi. Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.

Can you help solve the mystery by finding out what‘s the maximum value of the gold sticks Xiu Yang could have taken?
 

 

Input
The first line of the input gives the number of test cases, T(1T100). T test cases follow. Each test case start with two integers, N(1N1000) and L(1L2000), represents the number of gold sticks and the length of the container stick. N lines follow. Each line consist of two integers, ai(1ai2000) and vi(1vi109), represents the length and the value of the ith gold stick.
 

 

Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the maximum value of the gold sticks Xiu Yang could have taken.
 

 

Sample Input
4 3 7 4 1 2 1 8 1 3 7 4 2 2 1 8 4 3 5 4 1 2 2 8 9 1 1 10 3
 

 

Sample Output
Case #1: 2 Case #2: 6 Case #3: 11 Case #4: 3
Hint
In the third case, assume the container is lay on x-axis from 0 to 5. Xiu Yang could put the second gold stick center at 0 and put the third gold stick center at 5, so none of them will drop and he can get total 2+9=11 value. In the fourth case, Xiu Yang could just put the only gold stick center on any position of [0,1], and he can get the value of

 

分析:dp[i][j][k]表示决定前i个物品的取舍情况时,所用容器长度为j,

有k个物品重心放在边缘的最大价值,

状态转移方程:dp[i][j][k]=max(dp[i-1][j][k],dp[i-1][j-len[i]][k]+value[i]),(j>=need[i],即max(放第个,不放第i个)),

当k>0时,还有dp[i][j][k]=max(dp[i-1][j][k],dp[i][j-len[i]/2][k-1]+value[i]),(即max(不放第i个,第i个重心放在边缘)),

先把容器容量和每个物品的长度都乘2,避免出现小数,写的时候把三维数组优化成二维数组。

 

技术分享图片
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int len[1002],value[1002];
long long dp[4003][3];
int main()
{
    int T,cas=0,N,M;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&N,&M);
        M*=2;
        long long ans=0;
        for(int i=1;i<=N;i++)
        {
            scanf("%d%d",&len[i],&value[i]);
            len[i]*=2;
            ans=max(ans,(long long)value[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=N;i++)
        {
            for(int j=M;j-len[i]/2>=0;j--)
            {
                for(int k=0;k<3;k++)
                {
                    if(j>=len[i]) 
                        dp[j][k]=max(dp[j][k],dp[j-len[i]][k]+value[i]);
                    if(k>0)
                        dp[j][k]=max(dp[j][k],dp[j-len[i]/2][k-1]+value[i]);
                    ans=max(ans,dp[j][k]);
                }
            }
        }
        printf("Case #%d: %lld\n",++cas,ans);    
    }
    return 0;
}
View Code

 

hdu5543(Pick The Sticks) 01背包

标签:arm   too   cond   led   overlap   bsp   outside   cep   log   

原文地址:https://www.cnblogs.com/ACRykl/p/8660678.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!