码迷,mamicode.com
首页 > 其他好文 > 详细

1005. Spell It Right (20)——PAT (Advanced Level) Practise

时间:2014-09-23 19:20:05      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:advanced level   pat   1005   spell it right   

题目信息:

1005. Spell It Right (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five


代码如下:

#include <iostream>
#include <stack>
#include <iterator>
#include <algorithm>
using namespace std;

int main()
{
	char *str[10] = { "zero", "one", "two", "three", "four", "five",
		"six", "seven", "eight", "nine" };
	unsigned int sum = 0;
	char ch[101];
	cin >> ch;
	for (int i = 0; ch[i] != '\0'; i++)
	{
		sum += ch[i] - '0';
	}
	stack<int> res;
	if (sum == 0)
		res.push(0);
	while (sum)
	{
		res.push(sum % 10);
		sum /= 10;
	}
	cout << str[res.top()];
	res.pop();
	while (!res.empty())
	{
		cout << " " << str[res.top()];
		res.pop();
	}
	cout << endl;
	return 0;
}


1005. Spell It Right (20)——PAT (Advanced Level) Practise

标签:advanced level   pat   1005   spell it right   

原文地址:http://blog.csdn.net/xianyun2009/article/details/39501113

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!