码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1020 Encoding【连续的计数器重置】

时间:2018-04-04 00:39:01      阅读:334      评论:0      收藏:0      [点我收藏+]

标签:class   other   nta   put   code   des   accept   rip   title   

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51785    Accepted Submission(s): 23041


Problem Description
Given a string containing only ‘A‘ - ‘Z‘, we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, ‘1‘ should be ignored.
 

 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A‘ - ‘Z‘ and the length is less than 10000.
 

 

Output
For each test case, output the encoded string in a line.
 

 

Sample Input
2 ABC ABBCCC
 

 

Sample Output
ABC A2B3C
 

 

Author
ZHANG Zheng
 

 

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<set>
#include<map>
#include<sstream>
#include<queue>
#include<cmath>
#include<list>
#include<vector>
#include<string>
using namespace std;
#define long long ll
const double PI = acos(-1.0);
const double eps = 1e-6;
const int inf = 0x3f3f3f3f;
const int N = 500005;
int n, m, tot;
int a[N];

map<string,int> mp;
int main()
{
    int t;
    cin >> t;
    string s;
    while(t--)
    {
        int c = 1;
        cin >> s;
        for(int i=0; i<s.size(); i++)
        {
            if(s[i+1]==s[i]){
                c++;
            }
            else{
                if(c==1){
                    printf("%c",s[i]);
                    c = 1;
                }
                else{
                    printf("%d%c",c,s[i]);
                    c = 1;
                }
          }

       }
       cout<<endl;
    }
}

 

HDU 1020 Encoding【连续的计数器重置】

标签:class   other   nta   put   code   des   accept   rip   title   

原文地址:https://www.cnblogs.com/Roni-i/p/8712162.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!