码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1241 Oil Deposits(八方向简单深搜,对新手挺经典)

时间:2014-09-23 21:21:15      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:深搜   dfs   初级搜索   

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12461 Accepted Submission(s): 7245


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

Sample Output
0 1 2 2

本题是指@表示油点,*表示非油点,油点相邻则表示一个油点而不是多个,找出总油点个数。没啥技巧,就是八个方向搜索,


#include<iostream>
const int MAXN=100;
int map[MAXN+1][MAXN+1];
int t[8][2]={{0,1},{1,0},{0,-1},{-1,0},{1,1},{-1,1},{1,-1},{-1,-1}};//数组实现八方向
int m,n;
int judge(int x,int y)
{
	if(x>=0&&y>=0&&x<m&&y<n&&map[x][y])//判断是否满足继续深搜的条件
		return 1;
	return 0;
}
void dfs(int x,int y)
{
	map[x][y]=0;
	int tx,ty;
	for(int i=0;i<8;i++)
	{
			tx=x+t[i][0];//这里必须使用临时变量,不然x,y值不断变化,无法取到正确的结果
			ty=y+t[i][1];
			if(judge(tx,ty))
			{
				dfs(tx,ty);
			}
	}	
}
int main()
{
	int ans,i,j;
	char ch;
	while(std::cin>>m>>n&&m)
	{
		memset(map,0,sizeof(map));
		ans=0;
		getchar();
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				std::cin>>ch;
				if(ch=='@')
					map[i][j]=1;
			}
			getchar();
		}
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(map[i][j]==1)
				{dfs(i,j);ans++;}
			}
		}
		std::cout<<ans<<"\n";
	}
	return 0;	
}



hdu 1241 Oil Deposits(八方向简单深搜,对新手挺经典)

标签:深搜   dfs   初级搜索   

原文地址:http://blog.csdn.net/u014492609/article/details/39503489

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!