码迷,mamicode.com
首页 > 其他好文 > 详细

I - Secret Number (注意输出格式的方法)(在E-Box of Bricks中有)

时间:2018-04-04 21:15:41      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:panel   解决   blog   偶数   put   div   str   格式   sam   

有一天, KIKI 收到一张奇怪的信, 信上要KIKI 计算出给定数各个位上数字为偶数的和.
eg. 5548
结果为12 , 等于 4 + 8

KIKI 很苦恼. 想请你帮忙解决这个问题.

Input输入数据有多组,每组占一行,只有一个数字,保证数字在INT范围内.Output对于每组输入数据,输出一行,每两组数据之间有一个空行.
Sample Input

415326
3262

Sample Output

12

10



#include<iostream>
using namespace std;
int main()
{
 int t = 0;
 int n;
 while (cin >> n)
 {
  if (t != 0)
  {
   cout << endl;
  }
  t = 1;
  int num = 0;
  while (n)
  {
   if (n % 10 % 2 == 0)
   {
    num += n % 10;
   }
   n /= 10;
  }
  cout << num << endl;
 }
}

I - Secret Number (注意输出格式的方法)(在E-Box of Bricks中有)

标签:panel   解决   blog   偶数   put   div   str   格式   sam   

原文地址:https://www.cnblogs.com/damaoranran/p/8718516.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!