码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2058

时间:2018-04-05 20:58:51      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:img   分享   分析   turn   iss   pre   space   mission   col   

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29632    Accepted Submission(s): 8887


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

 

Sample Input
20 10
50 30
0 0
 
Sample Output
[1,4]
[10,10]
 
 
[4,8]
[6,9]
[9,11]
[30,30]
 
分析:设满足条件的区间为[a,a+k-1],那么M=a+(a+1)+......+(a+k-1)=k*a+k*(k-1)/2,
然后枚举k,算出a,记录结果。
 
技术分享图片
#include<cstdio>
long long a[1000000],num[1000000];
int main()
{
    long long N,M;
    while(scanf("%lld%lld",&N,&M))
    {
        if(!N&&!M) break;
        int cnt=0;
        long long k=1,temp;
        while(true)
        {
            temp=M-k*(k-1)/2;
            if(temp<=0) break;
            if(temp%k==0&&temp/k+k-1<=N)
            {num[cnt]=k-1;a[cnt++]=temp/k;}
            k++;
        }
        for(int i=cnt-1;i>=0;i--)
        printf("[%lld,%lld]\n",a[i],a[i]+num[i]);
        printf("\n");
    }
    return 0;
}
View Code

 

hdu2058

标签:img   分享   分析   turn   iss   pre   space   mission   col   

原文地址:https://www.cnblogs.com/ACRykl/p/8724130.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!