码迷,mamicode.com
首页 > 其他好文 > 详细

poj1195--Mobile phones(二维树状数组)

时间:2014-09-23 22:43:15      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   os   ar   strong   for   div   

Mobile phones
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 15182   Accepted: 7013

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 
bubuko.com,布布扣

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source

IOI 2001

 

简单的二维树状数组求区域和,注意xy的坐标,要保证从1开始。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 1100
int c[maxn][maxn] , n ;
int f(int x)
{
    return x & -x ;
}
void add(int x,int y,int a)
{
    int i , j ;
    for(i = x ; i <= n ; i += f(i))
    {
        for(j = y ; j <= n ; j += f(j) )
            c[i][j] += a ;
    }
    return ;
}
int sum(int x,int y)
{
    int ans = 0 , i , j ;
    for(i = x ; i >= 1 ; i -= f(i) )
    {
        for(j = y ; j >= 1 ; j -= f(j) )
            ans += c[i][j];
    }
    return ans ;
}
int main()
{
    int k , i , j , x1 , y1 , x2 , y2 , a , temp ;
    scanf("%d %d", &k, &n);
    memset(c,0,sizeof(c));
    while(1)
    {
        scanf("%d", &k);
        if(k == 3)
            break;
        if(k == 1)
        {
            scanf("%d %d %d", &x1, &y1, &a);
            x1++ ;
            y1++ ;
            add(x1,y1,a);
            continue ;
        }
        scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
        x1++ ;
        y1++ ;
        x2++ ;
        y2++ ;
        temp = sum(x2,y2) + sum(x1-1,y1-1) - sum(x1-1,y2) - sum(x2,y1-1);
        printf("%d\n", temp);
    }
    return 0;
}

poj1195--Mobile phones(二维树状数组)

标签:des   style   http   io   os   ar   strong   for   div   

原文地址:http://blog.csdn.net/winddreams/article/details/39504837

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!