码迷,mamicode.com
首页 > 其他好文 > 详细

Euclid's Game

时间:2018-04-08 21:17:44      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:multi   cts   ott   using   first   mission   any   ==   may   

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 6
Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
         25 7

11 7
4 7
4 3
1 3
1 0

an Stan wins.
 
Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 
Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
 
Sample Input
34 12
15 24
0 0
 
Sample Output
Stan wins
Ollie wins
 
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
	int n,m;
	while(cin>>n>>m)
	{
		if(n==0&&m==0)break;
		int cnt=0;
        int ans=0;
        while(1)
		{
           if(n<m)swap(n,m);
           ans=n/m;
           if(ans>=2)break;
           cnt++;
           n%=m;
           if(n==0)
		   {
               cnt++;
               break;
           }                
        }
       if(cnt%2==1)cout<<"Ollie wins"<<endl;
       else cout<<"Stan wins"<<endl;;
   }
   return 0;
 } 

  

Euclid's Game

标签:multi   cts   ott   using   first   mission   any   ==   may   

原文地址:https://www.cnblogs.com/minxuan/p/8747256.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!