码迷,mamicode.com
首页 > 其他好文 > 详细

D - An easy problem

时间:2018-04-10 15:22:19      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:cat   follow   inpu   i++   经验   efi   file   and   lse   

We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
  We can define sum(n) as follow:
  if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
  Is it very easy ? Please begin to program to AC it..-_-

Input  The input file contains multilple cases.
  Every cases contain only ont line, every line contains a integer n (n<=100000).
  when n is a negative indicate the end of file.Output  output the result sum(n).
Sample Input

1
2
3
-1

Sample Output

1
3
30

刚开始看题里面用递归!就用了递归发现超内存了。于是就打表了。注意了,下次可以吸取这次的经验。
#include<iostream>
using namespace std;
#define N 100002
int main()
{
long long num[N],i;
num[0] = 0;
for ( i = 1; i < N; i++)
{
if (i % 3) num[i]=num[i - 1] + i;
else num[i]=num[i - 1] + i*i*i;
}
int n;
while (cin >> n)
{
if (n < 0) break;
cout << num[n] << endl;
}
return 0;
}


D - An easy problem

标签:cat   follow   inpu   i++   经验   efi   file   and   lse   

原文地址:https://www.cnblogs.com/damaoranran/p/8778264.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!