码迷,mamicode.com
首页 > 其他好文 > 详细

hdu-2141(二分查找+暴力)

时间:2018-04-10 21:57:12      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:res   ber   man   scan   desc   cond   lan   HERE   UI   

Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3

 


1
4
10

Sample Output
Case 1:
NO
YES
NO

题目大意
给A,B,C三个序列,分别从这三个序列中找三个数,若存在三个数之和等于X,则输出”YES”,否则输出”NO”

解析
三重循环的搜索肯定是不能用的。我的解法是将a+b的值存到ab数组中,将该数组排序。再用二分搜索判断x-c是否存在于该数组中,若存在,则证明存在x=a+b+c,输出’YES’即可。若对于所有c,都不存在x-c属于该数组,则证明不存在x=a+b+c,输出’NO’即可。存在一定的技巧,下面贴一波代码

代码

#include <iostream>
#include<cstdio>
#include<algorithm>

using namespace std;

int main()
{
    int a[510],b[510],c[510],ab[250010];
    int l,n,m;
    int s;
    int x[1010];
    int kase=0;
    bool ans;
    while(scanf("%d%d%d",&l,&n,&m)!=EOF){
        kase++;
        for(int i=0;i<l;i++){
            scanf("%d",&a[i]);
        }
        for(int i=0;i<n;i++){
            scanf("%d",&b[i]);
        }
        for(int i=0;i<m;i++){
            scanf("%d",&c[i]);
        }
        scanf("%d",&s);
        for(int i=0;i<s;i++){
            scanf("%d",&x[i]);
        }
        for(int i=0;i<l;i++){
            for(int j=0;j<n;j++){
                ab[i*l+j]=a[i]+b[j];
            }
        }
        sort(ab,ab+l*n);
        printf("Case %d:\n",kase);
        for(int i=0;i<s;i++){
            ans=false;
            for(int j=0;j<m;j++){
                if(binary_search(ab,ab+l*n,x[i]-c[j])){
                    ans=true;
                    break;
                }
            }
            if(ans){
                printf("YES\n");
            }else{
                printf("NO\n");
            }
        }
    }

}

 

hdu-2141(二分查找+暴力)

标签:res   ber   man   scan   desc   cond   lan   HERE   UI   

原文地址:https://www.cnblogs.com/lklk/p/8782695.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!