码迷,mamicode.com
首页 > 其他好文 > 详细

foj 2111 Problem 2111 Min Number

时间:2018-04-13 20:31:21      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:图片   SM   max   tle   需要   for   enter   分享图片   cep   

Problem 2111 Min Number

Accept: 1025    Submit: 2022
Time Limit: 1000 mSec    Memory Limit : 32768 KB

技术分享图片 Problem Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits (‘0‘-‘9‘). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

技术分享图片 Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

技术分享图片 Output

For each test case, output the minimum number we can get after no more than M operations.

技术分享图片 Sample Input

3 9012 0 9012 1 9012 2

技术分享图片 Sample Output

9012 1092 1029 
 
思路:贪心模拟,头部尽量与尾部的最小值交换。
AC代码:
#include <iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#include<queue>
#include<string>
using namespace std;
#define N_MAX 10000+10
#define V_MAX 1000+10
#define INF 0x3f3f3f3f
int m;
string n;
void change(string &s,int n){//当前调整s的第n位
    char c=9+1;int id;
  for(int i=s.size()-1;i>n;i--){
     if(c>s[i]){
        if(n==0&&s[i]==0)continue;
        c=s[i];id=i;
      }
  }
  if(c<s[n])swap(s[n],s[id]);
}
int main(){
    int t;scanf("%d",&t);
    while(t--){
       cin>>n>>m;
       int cnt=0;
       string s;
       while(m){
            s=n;
       while(s==n&&cnt<s.size()-1){
        change(n,cnt);
          cnt++;
       }
       if(cnt>=s.size()-2)break;//已经不需要交换了
       m--;
       }
       cout<<n<<endl;
    }
    return 0;
}

 

foj 2111 Problem 2111 Min Number

标签:图片   SM   max   tle   需要   for   enter   分享图片   cep   

原文地址:https://www.cnblogs.com/ZefengYao/p/8822896.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!