标签:who clu imu led int content size while set
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big
bag with a volume of V ,and along his trip of collecting there are a lot of
bones , obviously , different bone has different value and different volume, now
given the each bone’s value along his trip , can you calculate out the maximum
of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of
cases.
Followed by T cases , each case three lines , the first line contain
two integer N , V, (N <= 1000 , V <= 1000 )representing the number of
bones and the volume of his bag. And the second line contain N integers
representing the value of each bone. The third line contain N integers
representing the volume of each bone.
Output
One integer per line representing the maximum of the
total value (this number will be less than 231).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
题意
最裸的01背包,给你背包总量和物品数,以及物品的价值和体积,让你求背包装满后的最大价值
#include<bits/stdc++.h>
using namespace std;
int main()
{
int t,N,V,i,j,w[1005],v[1005],dp[1005];
cin>>t;
while(t--)
{
memset(dp,0,sizeof dp);
cin>>N>>V;
for(i=1;i<=N;i++)
scanf("%d",&v[i]);
for(i=1;i<=N;i++)
scanf("%d",&w[i]);
for(i=1;i<=N;i++) //每一个骨头
for(j=V;j>=w[i];j--) //每个骨头的价值
dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
cout<<dp[V]<<endl;
}
return 0;
}
【HDU 2602】Bone Collector(裸的01背包)
标签:who clu imu led int content size while set
原文地址:https://www.cnblogs.com/kannyi/p/8877205.html